
 

Een volledige analyse workflow 

In de komende oefening wordt er gekeken naar het proces om een geschikte locatie te vinden voor een 

nieuwe basisschool in Arnhem. 

 

De locatie die we zoeken voor deze school moet aan een aantal criteria voldoen, bijvoorbeeld niet te dicht bij 

de snelweg, er moeten veel kinderen in de buurt wonen, niet te dicht bij bestaande scholen uiteraard en zo 

zijn er nog een criteria waar we later rekening mee gaan houden. 

 

We gaan bij deze school niet uit van nieuwbouw, er wordt een bestaande locatie gezocht. We hebben een 

bestand gekregen met alle bestaande gebouwen die te koop of voor een lange tijd te huur zijn. Deze 

gebouwen liggen door de hele gemeente Arnhem verspreid en we kijken in deze analyse of er een geschikt 

gebouw qua locatie tussen zit. 

 

Alle data die we in deze oefening gaan gebruiken voor de analyse is te vinden in de Arnhem.gdb 

(C:\EsriTraining\VAAP\Analyses) 

 

De oefening bestaat uit de volgende stappen: 

 

Stap 1: Data verkennen .................................................................................................................................. 1 

Stap 2: Schema maken .................................................................................................................................. 3 

Stap 3: De analyse ......................................................................................................................................... 3 

Stap 4: Analyseresultaat in kaart presenteren (optioneel) ........................................................................... 18 

Stap 1: Data verkennen 

We verkennen de data in deze stap in het Catalog paneel. Het Catalog paneel laat de data zonder 

opmaak/symbologie zien. We zijn dan mogelijk niet zo snel afgeleid en kunnen ons wat meer focussen op de 

data.  Het verkennen kan op twee manieren, met behulp van het Catalog paneel of met behulp van een 

(nieuwe) map. Catalog bekijkt de data zonder opmaak/symbologie, een map kan dit met opmaak. 

 

❑ Download de oefendata en pak deze uit in de folder C:\EsriTraining\VAAP. 

❑ In de folder C:\EsriTraining\VAAP\Analyses, open het ArcGIS Pro project Analyses.aprx.  

❑ Maak een folder connectie naar de locatie waar de cursusdata is opgeslagen (C:\EsriTraining\VAAP). 

❑ In het Catalog paneel, klik de rechter muisknop op de folderconnectie die u zojuist heeft aangemaakt en 

selecteer Add To New Projects. 

❑ Gebruik het Cataloog paneel om de data in de zojuist gemaakte folderconnectie te bestuderen (VAAP).  
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Voor het verder bestuderen van de data is het handig om alle stappen die nodig zijn voor het uiteindelijke 

resultaat eens op een rij te zetten. Op die manier kan de analyse op een ordelijke manier worden uitgevoerd.  

 

We hebben de volgende criteria om rekening mee te houden: 

 
1. De school moet in een buurt komen waar ten minste 150 leerlingen uit de doelgroep leeftijd wonen. 

 
2. De school moet 200 meter van een autosnelweg of hoofdweg liggen. 

 
3. De school mag niet in een straal van 500 meter van een bestaande school liggen. 

 
4. Er moet een groot sportveld gemaakt kunnen worden, dat wil zeggen er moet een grasland in de 

buurt liggen groter dan 20000 m2. 

 
5. De school moet ten minste 300 meter verwijderd zijn van een GSM mast. 

 

We gaan nu de data verder bestuderen met behulp van een de Catalog view en door deze toe te voegen aan 

een map.  

❑ Indien nodig, open de Catalog View (View > Catalog View). 

❑ Bestudeer de onderstaande datasets in de geodatabase (Arnhem.gdb).  

– Buurten (buurtgrenzen van het CBS) 

 

– Scholen (alle bestaande scholen) 

 

– GSM masten (alle locaties van GSM masten) 

 

– Gebouwen (alle gebouwen die te koop staan of te huur zijn) 

 

– WEGDEEL_LIJN (de weg-as van het Kadaster) 

 

– TERREIN_VLAK (terreingegevens van het Kadaster) 

 

 

 

 

❑ Om de datasets in nog meer detail te bestuderen, kunt u deze aan een nieuwe map toevoegen (Insert > 

New Map).  

Catalog View > Folders > Analyses > Arnhem.gdb 

 Een aantal van deze bestanden wordt opgeslagen in een feature dataset. In dat 

geval moet u dus een niveau verder klikken om deze te kunnen vinden. Er zijn meer 

datasets te vinden in de database dan alleen de hierboven vermelde datasets.  
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Stap 2: Schema maken 

 

 

 

 

❑ Maak nu op een kladpapier een schematische weergave van het proces. Op die manier weet u, wanneer 

u de stappen ook daadwerkelijk gaat uitvoeren en waar u exact zit in de analyse. We weten precies wat er 

na elke stap volgt. 

Stap 3: De analyse 

❑ Open nu in het project de map Arnhem.  

 

 

 

❑ Deze map bevat de CBS-buurten data en een basiskaart (basemap). Indien de CBS-buurten data nog niet 

zichtbaar is, maak deze zichtbaar in het Contents paneel.  

  Een goede manier om een grote complexe analyse te documenteren is het maken 

van een schema, een model. Voor de schematische weergave van zo’n analyse 

worden de volgende symbolen veel gebruikt: 

 

 

Een ovaal voor een databestand en een rechthoek voor een tool. 

Zo’n schema kan er zoals afgebeeld uitzien: 

 

 

 

 

 

Hoe meer men weet aan instellingen per tool hoe meer men ook al aan details kan 

beschrijven. Op deze manier wordt een model makkelijker leesbaar en ook makkelijk  

herhaalbaar of overdraagbaar naar een collega. 

 

 Catalog paneel > Maps > Arnhem 

Data Tool 

Terreinen 

Geschikte 

Terreinen 

Select 

Afstand tot 

bushalte 

Resultaat 
Ruimtelijke 

Selectie 

Buffer Bushaltes 
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❑ Bestudeer de attribuuttabel van de Buurten kaartlaag. 

 

 

De attribuuttabel bevat veel bevolkingsgegevens. Er is een kolom met een absoluut aantal inwoners per 

buurt: AANT_INW. Daarnaast is er een kolom met het percentage inwoners met hun leeftijd tussen de 0 en 

de 14 jaar, onze doelgroep voor de school. Deze kolom heet: P_0_14_JR.  

 

Het is voor onze analyse interessant om te weten wat het absolute aantal kinderen is binnen onze gewenste 

leeftijdsgroep. Om dit soort informatie te krijgen moeten we zelf hiervoor een kolom aanmaken en deze vullen 

met gegevens. Dit vullen kunnen we overigens enigszins geautomatiseerd doen. 
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❑ In de attribuuttabel klik op de Add knop. Het Fields venter opent.  

 

 

 

 

 

 

❑ Noem de nieuwe kolom Doelgroep. 

❑ Voor Type selecteer Long of Short Integer. 

❑ Bovenaan de ribbon, klik Save. 

We hebben nu een lege kolom aangemaakt. De volgende stap is deze kolom te vullen. 

 

❑ Sluit het Fields venster zodat we de attribuuttabel weer voor ons hebben. 

❑ Ga naar de zojuist aangemaakte nieuwe kolom. 

Wanneer we door de waarden heen lopen komen we voor een aantal buurten de 

waarde -9999998 tegen. Een waarde als deze is een gebruikelijke waarde om aan te 

geven dat er geen gegevens bekend zijn: een NoData waarde.  

 

Het is voor onze analyse niet erg dat dit soort NoData waarden voorkomen. Zoals te zien 

is komen dit soort waarden alleen voor in gebieden waar geen mensen wonen, 

bijvoorbeeld industriegebieden. 

 

 

Mocht het toevoegen van een veld op deze manier niet lukken, er is ook een Add 

Field tool beschikbaar in de Geoprocessing omgeving. 
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❑ Rechtsklik in de kolomtitel Doelgroep. 

❑ Selecteer Calculate Field.  

We hebben meerdere scripting talen om onze syntax mee op te bouwen. We gebruiken in deze stap Python. 

We maken dus een stuk programmeercode waarmee we een nieuwe kolom vullen met een waarde die per 

buurt het aantal kinderen berekent. 

 

❑ Controleer of de Expression Type op Python staat.  

We gaan het veld berekenen met een stuk Python code. 

 

❑ Vul nu de volgende expressie in: 

 

!AANT_INW!  *  !P_0_14_JR!  /   100 

 

 

 

 

 

 

❑ Klik OK. 

❑ Bekijk het resultaat in de tabel. 

 U voorkomt fouten door de expressie niet zelf te typen maar door deze uit de Fields 

lijst te dubbelklikken. 
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❑ Sluit de attribuuttabel. 

We zijn voor de school op zoek naar gebieden waar ten minste 150 potentiële leerlingen wonen. De 

buurtentabel bevat deze informatie over de doelgroep.  

❑ In de ribbon, op het Map tabblad, selecteer Select By Attributes. 

❑ Vul de volgende expressie in:  

Doelgroep is Greater Than 150 

 

 

❑ Klik OK. 

De wijken die voldoen aan onze query worden geselecteerd. Voor het gemak in ons analyseproces maken 

we hier een aparte laag van. 

 

❑ In het Contents paneel, rechtsklik de Buurten laag. 

❑ Selecteer Data > Export Features. 

❑ Noem de nieuwe featureklasse GeschikteBuurten.  

❑ Sla de featureklasse op in de default geodatabase (Analyses.gdb).  

De nieuwe laag wordt toegevoegd aan de map.  

❑ In het Map tabblad, bij Selection, klik op Clear om de selectie te verwijderen.  
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❑ Geef de nieuwe laag (C:\EsriTraining\VAAP) een andere kleur dan de Buurten laag (bijvoorbeeld zoals 

in onderstaande afbeelding).  

 

We zoeken alle bestaande, geschikte locaties voor de school binnen deze geschikte buurten. Aangezien we 

uitgaan van bestaande bebouwing, moeten we de bestaande bebouwing toevoegen.  

De volgende stap is het filteren van deze gebouwen. 

❑ Voeg de featureklasse Gebouwen toe. 

 

 

❑ Op het Map tabblad van de ribbon, selecteer de Select By Location tool. 

❑ Selecteer alle gebouwen volledig binnen de geschikte buurten.  

 

 

❑ Klik OK. 

Ook van deze selectie maken we een aparte laag aan.  

 

 Deze staat in Arnhem.gdb. 
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❑ In het Contents paneel, rechtsklik de Gebouwen laag. 

❑ Selecteer Data > Export Features. 

❑ Noem de nieuwe featureklasse naar PotentieleGebouwen en sla deze op in de Analyses.gdb.  

De nieuwe laag wordt toegevoegd aan de map.  

❑ Zet de Gebouwen laag uit. 

De scholen moeten niet al te dicht bij de grote wegen liggen in Arnhem, dit in verband met fijnstof en lawaai. 

We gaan een buffer maken rondom deze wegen zodat we alle potentiële locaties binnen deze buffer kunnen 

verwijderen. 

 

❑ Voeg de wegen toe aan de map. Dit bestand heet WEGDEEL_LIJN (in de Top10NL feature dataset). 

❑ Hernoem deze laag voor het gemak Wegen. 

Deze wegen bevatten een attribuut dat beschrijft of een weg bijvoorbeeld een snelweg of een lokale weg is.  

 
❑ Gebruik de Select By Attributes tool om een query te maken die alle lijnstukken selecteert die de 

typeaanduiding autosnelweg of hoofdweg hebben gekregen.  
 

 

❑ Klik OK. 

❑ Ook dit resultaat is een selectie. Maak net als in de vorige twee stappen hier een aparte featureklasse van 

en noem deze OverlastWegen. 

❑ Verwijder de Wegen laag om de weergave in de Map wat eenvoudiger te houden. 

Deze nieuwe laag (OverlastWegen) is de laag die als input dient voor de bufferanalyse. We willen immers in 

een strook rondom deze wegen geen school plaatsen. 

❑ Open de Buffer tool. 
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❑ Voor Input Features selecteer OverlastWegen. 

❑ Voor Output Feature Class typ WegBuffer200m. 

❑ Stel de afstand in op 200 meter. 

Het resultaat moet straks een grote bufferpolygoon worden. We hoeven geen individuele buffervlakken te 

hebben per wegsegment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Deze zit op het Analysis tabblad van de ribbon. 

❑ Dissolve type NONE zal individuele bufferpolygonen aanmaken. Elk lijnstuk dat 

gebufferd wordt zal een aparte buffer feature krijgen. 

❑ De optie ALL zal alle individuele buffers versmelten (‘dissolven’) naar 1 polygoon. Dit geeft 

een rustiger beeld. 

❑     

               NONE          ALL 

❑ Er is nog een derde optie LIST. Hierbij moet de gebruiker aangeven aan de hand van een 

attribuut welke buffers al dan niet met elkaar mogen versmelten. 
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❑ Bij Dissolve Type selecteer Dissolve all output features into a single feature. 

 

 

❑ Klik Run. 

❑ Zet de OverlastWegen kaartlaag uit om de buffer goed te zien. .  

❑ Bekijk het resultaat. 

 

  

De kleuren in uw kaart kunnen afwijken. Ter verduidelijking van het resultaat zijn hier enkele kaartlagen uitgezet.  

Het toevoegen van GSM masten zijn de volgende stap. We willen niet dat er een GSM mast binnen 300 

meter van een school staat, daarom maken we een buffer van 300 meter rondom de GSM masten.  

 

❑ Voeg de GSM masten featureklasse toe. 
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❑ Indien nodig, open nogmaals de Buffer tool. 

❑ Voor Input Features, selecteer GSM_masten. 

❑ Voor Output Feature Class, typ GSM_mastenbuffer300m. 

❑ Stel de afstand op 300 meter in. 

❑ Laat de rest van de instellingen staan.  

Het wel of niet ‘dissolven’ is bij deze buffers niet heel erg relevant voor deze analyse.  

 

 

❑ Klik Run. 

 

 

De kleuren in uw kaart kunnen afwijken. Ter verduidelijking van het resultaat zijn hier enkele kaartlagen uitgezet.  

❑ U kunt de GSM_masten kaartlaag uitzetten.  
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De nieuwe school moet uit de buurt liggen van de bestaande scholen. 500 meter uit de buurt is voldoende. 

 

❑ Voeg de Scholen featureklasse toe. 

❑ Indien nodig, open voor de laatste keer de Buffer tool. 

❑ Voor Input Features, selecteer Scholen. 

❑ Voor Output Feature Class typ ScholenBuffer500m. 

❑ Stel de afstand op 500 meter in. 

 

 

❑ Klik Run. 
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❑ U kunt de Scholen kaartlaag uitzetten. 

❑ Voeg de terreinvlakken toe aan de map. 

 

 

 

 

 

❑ Open de Select By Attributes tool. 

❑ Geef de volgende syntax op: 

TYPELANDGE is Equal to grasland 

AND Shape_Area is Greater Than 20000 

 

 

❑ Klik OK. 

❑ In het Contents paneel, rechtsklik de terreinvlak laag. 

❑ Selecteer Data > Export Features. 

❑ Noem de nieuwe featureklasse PotentieleSportvelden.  

❑ Verwijder de terreinvlak laag uit de Map zodat de weergave wat rustiger wordt.  

U heeft deze laag nu ook niet meer nodig. 

Nu zijn we op het moment aanbeland dat we alle tussenstappen van de analyse gereed hebben. We moeten 

nu alleen nog de laatste bestanden in een ruimtelijke bevraging stoppen om de meest geschikte school 

locatie te vinden.   

 

❑ Open de Select By Location tool. 

In de cursusdata folder staat een terreinvlak.lyrx bestand met de juiste symbologie. 
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❑ Vul het venster in zoals hier is afgebeeld. 

 

 

❑ Klik OK. 

Het resultaat van deze analyse is een selectie van alle potentiële gebouwen binnen de overlastzone van de 

weg. U zou dit kunnen zien als de eerste afvallers (wat betreft gebouwen) in deze analyse.  

 

We willen echter rekening houden met meer factoren, zoals de GSM masten en de bestaande scholen, dus 

we gaan nog verder met dit type van selecteren. 

 

Om eenvoudig verder te kunnen, draaien we nu de selectie om, zodat we stap voor stap gebouwen van onze 

gebouwenselectie verwijderen zodat er nog maar een paar overblijven. 

❑ Open de attribuuttabel van de PotentiëleGebouwen. 

❑ Klik op de Switch knop 

 

  

 

 

 

Het resultaat is nu een selectie van alle PotentiëleGebouwen, zonder nog rekening te houden met de GSM 

masten en bestaande scholen. Die laatste twee criteria filteren we er nu uit. 

 

❑ Open de Select By Location tool. 

❑ Bij het onderste veld Selection type, selecteer Remove from the current selection. 

Hierdoor gaat u de bestaande selectie verder verkleinen. 

❑  Voor Input Feature Layer, selecteer PotentiëleGebouwen. 

 Let op: Er kan bij grote datasets een waarschuwing komen dat dit wat tijd gaat 

kosten. Klik in dit geval op Ja. 
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❑ Voor Relationship (de ruimtelijke relatie), selecteer Intersect. 

❑ Voor Selecting Features, selecteer Scholenbuffer500m 

 

 

❑ Klik Apply. 

U gaat nu de selectie verder verkleinen door de GSM masten buffer mee te nemen. 

 

❑ Mocht de Select By Location tool gesloten zijn, open deze tool dan opnieuw. 

❑ Bij het onderste veld Selection type, selecteer Remove from the current selection.  

❑ Voor Input Feature Layer, selecteer PotentiëleGebouwen. 

❑ Voor Relationship (de ruimtelijke relatie), selecteer Intersect. 

❑ Voor Selecting Features, selecteer GSM_mastenbuffer300m. 

 

 

❑ Klik Apply.  
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Als laatste gaan we nu kijken of er binnen deze selectie van gebouwen een mogelijk sportveld in de buurt ligt. 

 

❑ Mocht de Select By Location tool gesloten zijn, open deze tool dan opnieuw. 

❑ Bij het onderste veld Selection type, selecteer Select subset from the current selection. 

❑  Voor Input Feature Layer, selecteer PotentiëleGebouwen. 

❑ Voor Relationship (de ruimtelijke relatie), selecteer Within a Distance. 

❑ Voor Selecting Features, selecteer PotentiëleSportvelden. 

❑ Gebruik een afstand van 50 meter.  

 

 

❑ Klik OK. 

Als alles goed is verlopen is er één gebouw die voldoet aan al deze criteria. 

 

❑ Rechtsklik op PotentieleGebouwen laag en maak hier ook weer een aparte featureklasse van de selectie 

(Data > Export Features). 

❑ Noem de laag NieuweBasisscholen. 
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❑ Sla het ArcGIS Pro project op en ga eventueel door met de volgende stap. 

Stap 4: Analyseresultaat in kaart presenteren (optioneel) 

Maak een mooie kaartopmaak/lay-out van dit analyseresultaat. Maak zo nodig gebruik van een extra 

dataframe om de locatie van de scholen wat meer naar voren te halen. 

 

❑ Denk hierbij aan legenda, noordpijl, schaalbalk, titel. 

❑ Denk bij dit mogelijke extra dataframe aan bijvoorbeeld de Extent Indicator. 

 

Dit is het einde van de oefening. 

 


